Welcome to my website, have a nice day!
Dream it, Do it, Make it!

CENTOS 8安装docker-ce出现requires containerd.io >= 1.2.2-3错误解决


yum install docker-ce docker-ce-cli containerd.io


[root@huidukongjian-h1 ~]#  yum install docker-ce docker-ce-cli containerd.io
Last metadata expiration check: 0:13:10 ago on Sun 08 Mar 2020 04:23:54 AM UTC.
 Problem: package docker-ce-3:19.03.7-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package containerd.io-1.2.10-3.2.el7.x86_64 is excluded
  - package containerd.io-1.2.13-3.1.el7.x86_64 is excluded
  - package containerd.io-1.2.2-3.3.el7.x86_64 is excluded
  - package containerd.io-1.2.2-3.el7.x86_64 is excluded
  - package containerd.io-1.2.4-3.1.el7.x86_64 is excluded
  - package containerd.io-1.2.5-3.1.el7.x86_64 is excluded
  - package containerd.io-1.2.6-3.3.el7.x86_64 is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


手动下载并安装,下载地址: https://download.docker.com/linux/centos/7/x86_64/stable/Packages/


[root@huidukongjian-h1 ~]# wget https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.3.7-3.1.el7.x86_64.rpm

[root@huidukongjian-h1 ~]# sudo yum -y install ./containerd.io-1.3.7-3.1.el7.x86_64.rpm
未经允许禁止转载:Ddmit » CENTOS 8安装docker-ce出现requires containerd.io >= 1.2.2-3错误解决